LATEST VERSION: 8.2.8 - CHANGELOG
Pivotal GemFire® v8.2

Installing on Linux and Solaris

Installing on Linux and Solaris

You install the native client on Linux and Solaris by extracting the contents of a ZIP file. After installation, you add environment settings.

Installation Prerequisites

Before you install the Pivotal GemFire native client, you must complete the following prerequisites:

  • Confirm that your system meets the hardware and software requirements described in Pivotal GemFire Native Client Supported Configurations.
  • From the Pivotal GemFire download page, select Download.
  • Under File Groups, select and download the Pivotal GemFire native client .zip file appropriate for your operating system and hardware architecture.
    • For Linux platforms, download Pivotal_GemFire_NativeClient_Linux_architecture_xxxx_bNNNN.zip where architecture equals either 32bit or 64bit, xxxx represents the four-digit version of the product and bNNNN corresponds to the build number for the release.
    • For Solaris platforms, download Pivotal_GemFire_NativeClient_Solaris_architecture_xxxx_bNNNN.zip where architecture equals either 32bit or 64bit, xxxx represents the four-digit version of the product and bNNNN corresponds to the build number for the release.

Installation Path for Linux

The default installation path is NativeClient_Linux_architecture_xxxx_bNNNN and reflects the architecture, product version and build number identified in the filename of the installer .zip file.

Installation Path for Solaris

The default installation path is NativeClient_Solaris_architecture_xxxx_bNNNN and reflects the architecture, product version and build number identified in the filename of the installer .zip file.

Environment Settings

When the installation is complete, you add these environment settings:

  • Set the GFCPP environment variable to productDir, where productDir represents the NativeClient__platform_architecture_xxxx directory (where platform is the OS you are installing upon, architecture is 32bit or 64bit, and xxxx is the four-digit product version)
  • Add $GFCPP/bin to the PATH
  • Add $GFCPP/lib to the LD_LIBRARY_PATH.